The Lowercase w

Post info:

I finally have a Home Lab!!

I’ve been wanting a home lab for quite a long time!  A few years ago, on an old PC, I used AutoLab to deploy a home lab. It used the internal HD in my PC to automatically deploy 2 nested hosts inside VMware Workstation, along with a virtual switch VM, a NAS VM, etc.  The PC only had 16gb of ram and a 3TB SATA HD.  It worked, but it was PAINFULLY slow!  A few months later, my OS crashed and I needed to rebuild.  Stupidly, I used a 32bit version of windows to reinstall, and there went my ability to use my lab as VMware Workstation only supports x64 OS’s.

Fast forward to 2017.  My friend Brian (@bspagna) realized that he still had some old home lab hardware laying around that he wasn’t using anymore (he had upgraded to a pair of Dell R610s).  A short time later, I was in possession of the hosts he had built back in the 2012 time frame, based on a blog post by Jase McCarty.  I had purchased a Synology NAS earlier in the year to use as storage for a media server.  The media PC that I owned was having issues and crashed, so I needed something new.  The Synology gave me more room to store my media collection, as well as having built in support for Plex.

Next, I needed something to support the network aspect of my lab.  Brian (@bspagna) recommended the Cisco small business edition switches.  They offered many of the features as the enterprise level switches used in large scale environments (vLANs, Layer 2/3 Networking, etc).  I ended up purchasing a Cisco SG300-20 switch off of Amazon.  It was pretty easy to setup as it has a GUI management interface, as well as the CLI.  The CLI commands are a little different from the Enterprise level switches, but I managed to get it setup.  Special thanks to my friend Rick, who helped me figure out the routing to get internet access in my lab, etc.  🙂

The servers I was using didn’t have any internal HDs in them.  I decided to use USB Flash Drives for the OS and spend the money on HDs for the Synology.  I had two empty bays in my 5 bay unit, so I added 2 SSD HDs, to give myself SATA and SSD tiers of storage for my lab.  I allocated two 1TB Datastores on my SATA drives and added two 500gb SSDs (in raid-1) to give myself a 500gb SSD datastore as well.  I installed ESXi 6.5 on both of the Flash Drives and I was off to the races.

Once I got everything cabled up the way I wanted, I was ready to start configuration.  Each PC has 5 connections.  One being dedicated to iKVM, I used the others to run 2 cables to my switch for Management/vMotion/VM traffic, and 2 cables to the switch for NAS traffic (NFS).  My Synology has 4 ports, so I ran two cables from the Synology to the switch, on top of the single cable that was already run for the media server that goes to my router.  Now, I had fault tolerance on each host, as well as the Synology.  I configured a few vLANs on my switch.  One for VMHost Management traffic, one for vMotion traffic, 2 for VM usage, and one for NFS traffic.  I mounted the datastores that I had created to my first host via NFS.  The switch ports are in TRUNK mode for only the vLANs necessary.  This keeps the NFS traffic separate from everything else.

I created my first VM, which I used to build an Active Directory domain.  Once I had the VM online, patched, and ready, I was able to deploy my vCSA.  I had fun along the way getting routing to work properly in my lab so VMs could get to the internet.  Special thanks to my friend Rick for the assistance to get everything working properly!

Now, I have my vCSA deployed and running.  I created a Virtual Distributed Switch, added my hosts, and created the proper vLANs.  I made sure both hosts could see the storage and the required vLANS.  Then, I decided to deploy the vRealize Log Insight appliance.  The hosts were complaining about local syslog storage, so I wanted to get something setup to collect logs incase I have future problems.  vRLI is a great tool for that.  It’s free for up to 10 hosts!

My next step is to setup a VM to run Plex from.  It’s not performing well on my Synology, so time to move the processing to another place!  I’ll start with 8gb ram and 2 cores and go from there!  The media library will still live on my Synology!

Here are pictures of the 2 hosts sitting on top of my Cisco SG300-20 switch, along with my Synology!

  

 

It’s nice to have something for ME to play with, while my son plays with his toys at home! 🙂

Ben Liebowitz, VCP, vExpert
NJ VMUG Leader

 

Share This:

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.